Reading Time: < 1 minute

HI All, this document deals with php-imap Requires: libc-client.so.2007()(64bit) error on centos.
I have faced this error during the installation of PHP-IMAP on one of the servers. After googling found this issue is happening due to dependency with the libc-client package which is not installed in my centos machine.

php
Fix

Step 1: Download and install the rpm package based on your Linux distribution from the below link

https://www.rpmfind.net/linux/rpm2html/search.php?query=libc-client.so.2007()(64bit)

In my case it is centos 6 , so I have chosen this package
https://www.rpmfind.net/linux/centos/6.10/os/x86_64/Packages/libc-client-2007e-11.el6.x86_64.rpm

Install the package

yum install https://www.rpmfind.net/linux/centos/6.10/os/x86_64/Packages/libc-client-2007e-11.el6.x86_64.rpm

step 2: Once installed above dependency is installed, install PHP-IMAP now.

yum install php-imap

NOTE: php-imap package differs based on the versions of php, default is php-imap

© 2020, Techrunnr. All rights reserved.

#1
#2
#3
Questions Answered
Articles Written
Overall Points
Categories: Linux

Prabhin Prabharkaran

He is Technical professional. He is a person who loves to share tricks and tips on the Internet. He Posts what he does!!

0 Comments

Leave a Reply